
Content Center: Migrate libraries and 

update associated Inventor files 

This Skill Builder guides you through migrating your Content Center libraries and updating the 

associated Inventor files.  The migration of the Content Center components is done in two steps. 

The first step is to migrate the Autodesk Data Management Server (ADMS). The second step is 

to update the Content Center data to the new version of Inventor and refresh the legacy 

assemblies. 

Perform the following steps to migrate and set up legacy user libraries: 

 Use ADMS Console to create a backup. 

 Uninstall the existing ADMS, and then install the new version of ADMS and Inventor. 

 Migrate legacy Content Center libraries to the new version of ADMS. 

 Configure Content Center libraries on the server. 

 Configure Content Center libraries in the Inventor project. 

 Update legacy user libraries by using Update Tool.  

 Refresh Content Center parts in legacy assemblies. 

Step 1: Use ADMS Console to create a backup 

Back up all ADMS data before you upgrade ADMS. Run ADMS Console, and select Tools > 

Backup from the ADMS Console menu. The Backup tool creates a backup of all libraries and 

vaults.   

Note: If the ADMS database is corrupted, use the backup file   to restore ADMS data and 

configuration as they existed at the backup time. In ADMS Console, click Tools>Restore from 

the menu.  

Step 2: Uninstall existing ADMS, and then install new version of ADMS and 

Inventor 

1. Uninstall the old version of ADMS.  

Note: Do not uninstall the SQL Server. The new ADMS version will detect and use it.  

2. Install the new version of ADMS. The installation detects legacy user libraries. After the 

installation finishes, it reminds you to migrate your libraries.  

 

Select Start the server console now and click OK to start the server console and migrate 

the existing database. An automated process migrates your vaults and libraries. You can 

select libraries to be available in the new Inventor version. If the process finished 

successfully, you can continue with step 5 of the library migration procedure. If you drop 

the automatic migration, you must migrate the database and configure the server 

manually. 

 



Tip: To defer the automatic migration, select Run the server console at a later time, and 

then click OK. The first time you launch the server console, you are prompted to migrate 

the existing database. 

3. Install Autodesk Inventor 2009. You can keep the old version of Autodesk Inventor on 

your computer and set up the Side-by-Side environment. See Appendix 1 for more 

information. 

Step 3: Migrate legacy Content Center libraries to the new version of ADMS 

If you used the automated process to migrate legacy user libraries, you can skip this step.  

If legacy user libraries were found during the installation, but you canceled their automatic 

migration, you must migrate them manually. These libraries are visible in the Libraries folder in 

the ADMS Console, they are marked by an exclamation mark icon, and are not available for use. 

1. Run ADMS Console. 

2. Expand the root and the Libraries item in the ADMS Console browser. 

3. Right-click the library to migrate, and select Migrate from the menu. 

4. Click OK to migrate the library to the new server version. The library is inserted in the 

partition corresponding to the Inventor version that was used to create the library. 

Notes:  

 Legacy user libraries must be migrated to the new server to be available for use. Migrated 

libraries are changed to conform to the new version of ADMS.  

 Migration of libraries is an irreversible process. Libraries can migrate to a newer version 

of library server only. Migrated libraries cannot be used with an older version of the 

library server. Create a backup before you migrate libraries. If needed, you can later 

restore the original libraries from the backup file. 

Step 4: Configure Content Center libraries on the server 

If you used the automated migration process to copy legacy user libraries to the appropriate 

partition, you can skip this step. 

After a legacy user library is migrated (during the installation or manually), it is added in a 

partition on the server. The partition corresponds to the Inventor version where the library was 

created. Legacy libraries are added either in the Autodesk Inventor 2008 partition or Autodesk 

Inventor 11 partition. You must copy libraries into the Autodesk Inventor 2009 partition to use 

them with Autodesk Inventor 2009. 

1. Run ADMS Console. 

2. In the ADMS Console window, expand Libraries, and right-click a library to copy. 

3. Choose Copy from the menu. 

4. In the Copy Library dialog box, enter the library name, select Autodesk Inventor 2009 

partition, and click OK. The library is copied into Autodesk Inventor 2009 partition. 



Note: After you finish, all libraries you want to use with Autodesk Inventor 2009 must be 

available in the Autodesk Inventor 2009 partition. 

Tips (Server Configuration):   

 To add standard libraries, run the installation Setup, select the libraries to install, and 

install them. 

 To move libraries between library servers, use the Export and Import ADMS commands.  

To export a library from the source server:  

1. Run ADMS Console.  

2. In the browser panel, expand the server root and the Libraries folder. 

3. Right-click a user library to export, and select Export from the menu. 

4. Specify the location for the exported library.  

Note: Export does not remove or change the original library. 

To import the library to the destination server: 

1. Run ADMS Console.  

2. Expand the root in the ADMS Console browser. 

3. Right-click the Libraries item, and select Import Library from the menu.  

4. Locate the .mdf file and click OK to import it. The library is inserted in the partition that 

corresponds to the Inventor version that was used to create the library. 

Step 5: Configure Content Center libraries in the Inventor project 

Content Center libraries must be configured in the Inventor project to be available in Content 

Center. 

1. Start Autodesk Inventor 2009.  Click File > Projects.  

2. In the Projects dialog box, click the Configure Content Center Libraries button. 

3. Add all legacy user libraries you want to use. To add a library, click the Add Library 

button in the Configure Libraries dialog box. Select the library in the Add Library dialog 

box, and then click OK. The library is added to the Libraries list.  

Note: An exclamation mark icon in front of a library name indicates that the library 

cannot be used in Content Center. You must update the library with the Update Tool. 

4. Click OK in the Configure Libraries dialog box.  

5. Click Save in the Projects dialog box to save the project.  

6. If appropriate, change the storage folder for Content Center parts. See the Inventor Help 

for more details. 

Tips: 



 If you use an existing project as a template for a new project, the Content Center 

configuration is inherited. 

 If you are a stand-alone user, define the appropriate library configuration for particular 

projects to keep the best Content Center performance. Remove all unused libraries from 

each project. 

 If you are an administrator of a workgroup, create a project file with the appropriate 

library configuration, copy the project to a shared location, and ask designers to include 

the project into their local projects. Then designers can add new libraries to their local 

projects but cannot remove libraries configured in the shared project. (Note: Vault does 

not support included projects.) 

 If a project is controlled by Vault or other data management system, it must be checked-

out to modify the library configuration.  

Step 6: Update legacy user libraries by using the Update Tool 

A legacy user library cannot be used in Content Center until it is converted by the Update tool. 

The Update Tool migrates legacy families, and then updates families whose parent family was 

changed. During the update, edits available in the source parent family are propagated to the 

child family in the user library. The changes in the family properties or parameters are preserved, 

but the data that you did not edit are changed to correspond to the source family. If you changed 

the family template file, your template file is overwritten after the family update.  Let the Update 

Tool create a backup of your template files and apply your templates to updated families.  

1. In the Projects dialog box, click the Configure Content Center Libraries button. 

2. Click the Update tool button.  

The Update Tool dialog box is displayed.  The legacy libraries to update are listed in the 

Following User Libraries are available for Update list.  

3. Select the library to update. If more than one user library is out of date, you can select 

several libraries to be updated in the same process. Then click Next. 

4. A library analysis is performed and results of the analysis are displayed. If any problems 

are found, you must solve them to continue. If no problems are found, the Backup options 

are displayed. Specify a folder to create a backup and click Next. 

Note:  Parent (source) families can be located in standard libraries or in user libraries. All 

standard libraries that include parent families must be available to run the Update Tool. If 

a user source library cannot be found, the Update Tool completes the migration, and then 

updates only families whose parents are available. Updating other families is postponed.  

5. After the process ends, review the Update report.  

Tip (Cross References between Libraries):  If there is a cross reference, and you have a 

user library (UL1) that includes source families for families in user library UL2, and UL2 

includes source families for families in user library UL1, you must attach both libraries 

and run the update tool step by step for UL1 and UL2. 

6. Click the Save As button to save the Update Report. Select the destination folder and 

click Save.  

7. Fix all sick families in the updated library (libraries). Sick families are marked with an 

icon in the Place from Content Center and Content Center Editor dialog boxes. They can 

be used in Content Center, but sick family members may cause unexpected problems. 



Problems that may appear in the updated library:  

Step 7: Refresh Content 

Center parts in legacy 

assemblies 

We recommend that you 

refresh standard components 

after you migrate an assembly 

into the new Inventor version. 

If the assembly is not 

refreshed, it may contain out-

of-date standard parts. When 

you perform a Content Center 

operation related to an out-of-

date standard part, the 

corresponding part file is 

“silently” refreshed. All 

occurrences of the out-of-date 

part are replaced by a new 

version of the part. Examples 

of operations that can cause a 

silent refresh are Change Size, 

Place from Content Center, and 

Open from Content Center.  

Currently there is no way how 

to automate the Refresh 

process. You must open each 

legacy assembly and refresh it.  

1. Open a legacy assembly 

file. 

2. Click Tools > Refresh 

Standard Components on the 

menu. An analysis of the assembly is performed. All out-of-date Content Center parts are 

found and displayed in the Standard Component Refresh dialog box.   

Note: If no standard parts are out-of-date, the refreshing process is finished. 

3. Review the Instance Status information and set Yes in the Update column to update the 

standard parts.  

4. Click OK to refresh the assembly.   

Note: If Content Center files are included in Vault (or in other data management system), 

the Refresh Standard Components tool must check out all out-of-date Content Center part 

files to replace them. Read-only parts cannot be refreshed and remain out-of date. 

Appendix 1: Side-by-Side installation 

Problem Possible Cause Solution 

A family 

table contains 

empty cells in 

numeric 

columns. 

A new column was added 

to the parent family table 

in the standard library. 

You copied that family in 

your legacy library and 

added a row to its table. 

Update Tool propagates 

the new column to the 

copied family, and a blank 

cell appears in the row 

added by you. 

Open the family table 

and enter an 

appropriate value to 

the blank cell. 

A family does 

not map all 

required 

category 

parameters. 

A required parameter was 

added to a category in the 

standard library. Your 

legacy library includes a 

family published in that 

category. The new 

required category 

parameter is not mapped 

to any column in the 

family table.  

Open the Mapping 

tab of the Family 

Properties dialog 

box, and map the 

required parameter to 

a column in the 

family table. 

A family 

requires 

authoring. 

A category in the standard 

library requires authoring. 

Your legacy library 

includes a family 

published in that category. 

The family template file 

does not contain the 

authoring information.  

Instantiate a family 

member and run the 

authoring tool for the 

part file. Then 

replace the family 

template with the 

authored file and 

define parameter 

mapping for required 

category parameters. 



To support Side-by-Side installation, the library server maintains Content Center libraries that 

were built for different Inventor versions. Libraries are saved in the corresponding partition on 

the server. Libraries in Autodesk Inventor 11 partition are used by Autodesk Inventor 11 with 

Client Update patch. Libraries in Autodesk Inventor 2008 partition are used by Autodesk 

Inventor 2008 with Client Update patch. Libraries in Autodesk Inventor 2009 partition are used 

by Autodesk Inventor 2009.  

To set up the Side-by-Side environment, follow the previous steps to install the new version of 

ADMS and Inventor. Than continue with the following steps: 

1. Copy user libraries to appropriate partitions on the server. Remember that each version of 

Autodesk Inventor can access only libraries included in the corresponding partition. 

2. Install Client Update patch for Autodesk Inventor 11 and Autodesk Inventor 2008. 

3. In Autodesk Inventor, edit or create projects. Configure Content Center libraries and set 

up the Content Center Files folders in particular projects. 

Note: You must use separate Content Center Files folders for each version of Inventor. 

Sharing the Content Center Files folder by different versions of Inventor would cause 

unpredictable replacing of standard parts in assemblies. 

Tip: See the CC_for_Inventor_2009_side_by_side_install.pdf document in the Setup folder of 

Autodesk Inventor for more information about Side-by-Side installation. 

Appendix 2: Work in Vault or other data management environment  

To refresh Content Center parts in assemblies:  

 If Content Center files are saved in Vault, the Refresh Standard Components tool must 

check out all out-of-date Content Center part files to replace them.  

 Refreshed Content Center files remain checked out when the refreshing process finishes. 

You must check the files in manually. 

 If the refreshing process cannot change the read-only status to read/write automatically, 

standard parts are not refreshed and remain out-of date. This problem appears if read-only 

standard parts are not saved in Vault, or if Inventor does not recognize that standard parts 

are saved in Vault (a single-user Inventor project is active, or standard parts were added 

to Vault by different Vaulted project). 

 Storage location for Content Center files:  

 If you work in Vault (or in another data management system) environment, each member 

of the workgroup must use a local folder to store Content Center files. The local Content 

Center Files folder should be controlled by the data management system.  

 Do not change the location of the Content Center Files folder   while a project is active. 

 


